July 2018 Maintenance Continued
Incident Report for New Innovations
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 22, 2018 - 00:08 EDT
Identified
We are finishing up our required monthly maintenance. Our site will be available shortly. Thank you for your patience while we complete this upgrades.
Posted about 1 year ago. Jul 21, 2018 - 23:46 EDT
This incident affected: Web Servers, Database Servers, Mail Services, Mobile Interface, Data Exchange Services, Support Site, and System Infrastructure.